Profil | Mitglieder | Registrieren | Start | Suche


PHP-Support.de » Programmierung » HTML, JavaScript & CSS » Aufbau falsch    » Hallo Gast [Login | Registrieren]

Neues Thema | Antworten   

Autor Beitrag
FRAGE007
Mitglied
Guter User


Dabei seit: 13.03.2009
Herkunft: Berlin
Posts: 372
     Aufbau falsch Zitat | Bearbeiten

Hallo,

ich habe ein mini Problem finde aber nicht raus wo das Problem ist.
Die Bilder sollen normal Horizontal sein im Ursprungscode geht dies auch
 PHP 
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
<div class="data-twin cfx">
    <div class="site_view">
        <ul class="gallery cfx">
            <li class="gallery_item"><a href="x" title=x" data-fancybox-group="gallery-9" class="fancybox"><img src="bilder/Hauptseite_Bild1.jpg" alt="x" width="320" height="320" /></a></li>
            <li class="gallery_item"><a href="x" title="x " data-fancybox-group="gallery-9" class="fancybox"><img src="bilder/Hauptseite_Bild1.jpg" alt="x" width="320" height="320" /></a></li>
            <li class="gallery_item"><a href="x" title="x" data-fancybox-group="gallery-9" class="fancybox"><img src="bilder/Hauptseite_Bild1.jpg" alt="x" width="320" height="320" /></a></li>
            <li class="gallery_item"><a href="x" title="xn " data-fancybox-group="gallery-9" class="fancybox"><img src="bilder/Hauptseite_Bild1.jpg" alt="praxis-04" width="320" height="320" /></a></li>
        </ul>
    </div>
</div>


nun habe ich alles in die Datenbank verlegen wollen mit diesem Code:
 PHP 
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:

<div class="data-twin cfx">
    <div class="site_view">
        <ul class="gallery cfx">
        <?php 
            
include_once('config.php');
            
$stmt $db->query("SELECT * FROM bilder_startseite ");
                    while(
$row $stmt->fetch(PDO::FETCH_OBJ))
               {
                echo 
"<li class='gallery_item'><a href='$row->url' title='$row->titel' data-fancybox-group='gallery-9' class='fancybox'><img src='$row->subimage' alt='$row->alt' width='320' height='320' /></a></li>";
            }
        
?>
        </ul>
    </div>
</div>
Nun sind die Bilder jedoch untereinander ?!

Hat jemand einen Tipp?





Post wurde schon 3x editiert, das letzte mal am 02.11.2018 um 09:54 von FRAGE007
02.11.2018, 09:48 Profil | PM | E-Mail  
FRAGE007
Mitglied
Guter User


Dabei seit: 13.03.2009
Herkunft: Berlin
Posts: 372
      Zitat | Bearbeiten

erledigt nachdem ich die Seite nun ein paar mal neu geladen hab stimmt es


02.11.2018, 09:55 Profil | PM | E-Mail  
Seiten (1):  1 
PHP-Support.de » Programmierung » HTML, JavaScript & CSS » Aufbau falsch   

Neues Thema | Antworten   


Powered by Command Board 1.0 - Beta 2.0 © 2004-08 PHP-Einfach | Impressum | Datenschutz